Установка и настройка - дополнение к конфигурации для 1С

1. Системные требования

Модуль «Простые звонки – 1С» поставляется в виде дополнения к конфигурации 1С и компонента ActiveX.

Внимание! Дополнение к конфигурации устанавливается один раз на конфигурацию 1С, которую вы хотите подключить к «Простым звонкам». Компонент ActiveX устанавливается на все компьютеры пользователей 1С и «Простых звонков».

Для установки дополнения к конфигурации 1С вам потребуется:
- Платформа 1С версии 8.1, 8.2, 8.3
- 1С конфигурация «Управление торговлей» версии 10.х, «Управление производственным предприятием» версии 1.2.х, 1.3.х.

Для установки и работы компонента ActiveX на компьютерах пользователей вам потребуется:
- Компьютер с операционной системой Windows XP, Windows Vista, Windows 7, Windows 8, Windows 10, Windows Server 2003, Windows Server 2008, Windows Server 2008 R2, Windows Server 2012, Windows Server 2012 R2
- Если пользователи работают с 1С 8.2, то приложение «толстый» клиент для 1С 8.2 (приложение «тонкий клиент» и web-интерфейс не поддерживаются!)

2. Проверьте перед установкой

Перед установкой и настройкой дополнения конфигурации 1С, пожалуйста, проверьте:

  • Вы сделали архивную копию базы 1С
  • Компьютер, на который вы устанавливаете дополнение к конфигурации 1С, удовлетворяет системным требованиям (см. «1. Системные требования»)
  • У вас есть доступ к базе 1С в режиме «Конфигуратора»
  • Вы можете войти в базу 1С с правами администратора
  • У вас есть файл ProstieZvonki_1C_82_UT11.cf с дополнением к конфигурации 1С
  • У вас есть адрес и порт АТС-коннектора «Простые звонки».

Перед установкой и настройкой компонента ActiveX на компьютеры пользователей, пожалуйста, проверьте:

  • Компьютеры пользователей, на которые вы устанавливаете компонент ActiveX, удовлетворяют системным требованиям (см. «1. Системные требования»)
  • У вас есть доступ к компьютерам пользователей с правами администратора операционной системы
  • У вас есть программа установки ProstieZvonki_1С_ActiveX.exe компонента ActiveX

3. Установка дополнения к конфигурации

3.1. Откройте базу 1С «Управление торговлей» версии 10.3 в режиме «Конфигуратора».

Внимание! Если вы пользуетесь другой конфигурацией (например, «Управление производственным предприятием»), другой версией конфигурации «Управление торговлей» или платформой 1С 8.2, то алгоритм действий и внешний вид экранов могут значительно отличаться.

3.2. Сделайте архивную копию базы («Администрирование» - «Выгрузить информационную базу»).

3.3. Выберите в главном меню «Конфигурация» - «Сравнить, объединить с конфигурацией из файла».

3.4. Выберите файл с дополнением конфигурации:
- ProstieZvonki_1C_81_UT10.cf для 1С версии 8.1
- ProstieZvonki_1C_82_UT10.cf для 1С версий 8.2 и 8.3

3.5. В окне сравнения и объединения конфигураций снимите галочки «Свойства», «Справочники», «Перечисления».

отмечаем галочки «Свойства» «Справочники» «Перечисления»

3.6. Разверните строку «Справочники» и для справочника «ВидыКонтактнойИнформации» установите галочку напротив свойства «Предопределенные».

устанавливаем галочку «Предопределенные»

3.7. Разверните строку «Регистры сведений» и у «КонтактнаяИнформация» оставьте галочки только у поля «Ресурсы».

оставляем галочку «Ресурсы»

3.8. Нажмите на кнопку «Выполнить». Произойдет обновление конфигурации.

3.9. При появлении диалогового окна, нажмите «Продолжить».

нажимаем кнопку «Продолжить»

3.10. Осталось вставить несколько процедур в модуль приложения, и в формы некоторых объектов. Для этого откройте модуль приложения (правой кнопкой мышки на корне конфигурации)

открываем модуль приложения

И в самом начале вставьте переменную CTI_Телефония:

в начала вставляем переменную CTI_Телефония

// CTI {
Перем CTI_Телефония Экспорт;
// } CTI

Найдите процедуру «ПриНачалeРаботыСистемы», и в ее конце вставьте код:

при начале работы системы

Если РольДоступна("ПолныеПрава") ИЛИ РольДоступна("CTI_Использование") Тогда
CTI_Телефония = Обработки.CTI_Телефония.Создать();
CTI_Телефония.ЗагрузитьКомпоненту();
CTI_ОбщийМодуль.ПроверитьПервыйЗапуск();
Если ЗначениеЗаполнено(CTI_ОбщийМодуль.ПолучитьВнутреннийНомерПользователя()) Тогда
CTI_Телефония.Подключиться();
КонецЕсли;
КонецЕсли;

Далее, найдите процедуру «ПриЗавершенииРаботыСистемы», и в ее конце вставьте код:

// CTI {
Если CTI_Телефония <> Неопределено Тогда
 CTI_Телефония.Отключиться();
КонецЕсли;
// } CTI

3.11. Добавим кнопку «Позвонить» на форму контрагента, а так же автоматическое заполнение номера телефона при создании нового контрагента.

Откройте форму справочника контрагента (правой кнопкой мыши – «Открыть основную форму объекта»).

открываем форму справочника

В открывшемся окне внизу переключитесь на закладку «Модуль»

переключаемся на закладку «Модуль»

Найдите процедуру «ПриОткрытии» и вставьте следующий код:

// CTI {
CTI_ОбщийМодуль.ДобавитьКнопкуПозвонить(ЭлементыФормы.ДействияФормы);
// } CTI

Вставьте процедуру обработчик нажатия на кнопку:

// CTI {
Процедура ДействияФормыПозвонить(Кнопка)
CTI_ОбщийМодуль.ПозвонитьКонтрагенту(Ссылка);
КонецПроцедуры
// } CTI

Вставьте в начало модуля следующий код:

// CTI {
Перем CTI_НомерТелефона Экспорт;
// } CTI

А затем в конце процедуры «ПередОткрытием» вставить следующий код:

// CTI {
Если ЗначениеЗаполнено(CTI_НомерТелефона) Тогда
Для Каждого Стр Из НаборКонтактнойИнформации Цикл
Если Стр.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон Тогда
Если НЕ ЗначениеЗаполнено(Стр.Представление) Тогда
Стр.Представление = CTI_НомерТелефона;
Стр.Поле3 = CTI_НомерТелефона;
Прервать;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
// } CTI

3.12. Добавим кнопку «Позвонить» на форму события
Откройте форму документа «Событие» (правой кнопкой мыши – «Открыть основную форму объекта», затем “Модуль”).

Найдите процедуру «ПриОткрытии» и вставьте следующий код:

// CTI {
CTI_ОбщийМодуль.ДобавитьКнопкуПозвонить(ЭлементыФормы.ДействияФормы);
// } CTI

Вставьте процедуру обработчик нажатия на кнопку:

// CTI {
Процедура ДействияФормыПозвонить(Кнопка)
Если СостояниеСобытия = Перечисления.СостоянияСобытий.Запланировано Тогда
CTI_Телефония.Параметры.АктивноеСобытие = ЭтотОбъект;
КонецЕсли;
CTI_ОбщийМодуль.ПозвонитьКонтрагенту(Контрагент);
КонецПроцедуры
// } CTI

3.13. Добавим автоматическое заполнение номера при создании контактного лица
Откройте модуль формы «ФормаВводаНового» справочника «КонтактныеЛицаКонтрагентов».

Вставьте в начало модуля следующий код:

// CTI {
Перем CTI_НомерТелефона Экспорт;
// } CTI

Затем, в конце процедуры «ПриОткрытии» вставьте следующий код:

// CTI{
Если НЕ ПустаяСтрока(CTI_НомерТелефона) Тогда
ГородскойМобильный = "";
ПредставлениеНомера =
CTI_Телефония.ПолучитьПредставлениеНомераТелефона(CTI_НомерТелефона,,ГородскойМобильный);
Если ГородскойМобильный = "Мобильный" Тогда
ВидТелефонаКонтактногоЛица =
Справочники.ВидыКонтактнойИнформации.МобильныйТелефонКонтактногоЛицаКонтрагента;
Иначе
ВидТелефонаКонтактногоЛица =
Справочники.ВидыКонтактнойИнформации.РабочийТелефонКонтактногоЛицаКонтрагента;
КонецЕсли;
НомерТелефонаКонтактногоЛица = ПредставлениеНомера;
КонецЕсли;
// }CTI

3.14. Добавим кнопку настройки «Простых звонков» в меню пользователя. Для этого в интерфейсе «Общий» в меню «Сервис» вставьте открытие формы.

добавляем кнопку настройки «Простые звонки»

В появившемся окне выберите «Общие» - «Общие формы» - «CTI_ФормаНастройки».

выбираем общие формы

Далее, для только что добавленного пункта меню нужно добавить иконку:

добаволяем иконку

3.15. Аналогичным способом, добавьте кнопку История разговоров в Интерфейсы->Полный->Отчеты- >Управление отношениями с клиентами. В качестве действия, выберите Регистры сведений – CTI_ИсторияЗвонков. Затем добавьте иконку так же, как для формы настроек.

3.16. Нажмите F7 для обновления конфигурации.

4. Установка компонента ActiveX на компьютеры пользователей 1С

Внимание! Если пользователи 1С работают с системой через терминальный доступ, то вам необходимо установить компонент ActiveX только на сервер терминального доступа, к которому подключаются пользователи.

Зайдите на компьютер пользователя 1С с правами администратора операционной системы.

Запустите программу установки компонента ActiveX ProstieZvonki_1С_ActiveX.exe. Установите компонент ActiveX для всех пользователей Windows, следуя инструкциям.

Повторите установку компонента ActiveX на остальных компьютерах пользователей «Простых звонков».

5. Настройка дополнения к конфигурации 1С

5.1. Откройте базу 1С «Управление торговлей» версии 10.3 в режиме «Конфигуратора».

Внимание! Если вы пользуетесь другой конфигурацией (например, «Управление производственным предприятием»), другой версией конфигурации «Управление торговлей» или платформой 1С 8.2, то алгоритм действий и внешний вид экранов могут значительно отличаться.

5.2. Тем пользователям 1С, которые будут работать с «Простыми звонками» необходимо назначить специальные права. Выберите в меню «Администрирование» - «Пользователи». Появится окно «Список пользователей».

открываем список пользователей

5.3. Двойным щелчком выберите нужного пользователя. В появившемся окне откройте вкладку «Прочие» и установите флажок «Простые звонки (пользователь)». Повторите для всех пользователей «Простых звонков».

выбираем пользователя для работы с простыми звонками

5.4. Каждому пользователю «Простых звонков» необходимо назначить внутренний номер – номер телефона сотрудника на офисной АТС. Выйдите из режима конфигуратора. Зайдите в режиме предприятия пользователем с правами администратора.

5.5. Выберите в главном меню «Сервис» - «Пользователи» - «Список пользователей». Откройте карточку необходимого пользователя. Откройте вкладку «Адреса и телефоны». Найдите строку «Телефон» - «Внутренний номер (Простые звонки)» и выберите ее двойным щелчком. В появившемся окне «Телефон» задайте необходимую информацию. Повторите для всех пользователей «Простых звонков».

Внимание! После установки/изменения внутреннего номера у пользователя, изменения вступят в силу только после перезапуска 1С клиента пользователем.

назначаем внутренний номер пользователя

5.6. Чтобы настроить подключение к АТС-коннектору «Простых звонков» выберите в меню «Сервис» - «Настройка (Простые звонки)».

5.7. В появившемся окне задайте адрес АТС-коннектора и пароль.

Внимание! Если вы не получили или не знаете адрес сервера «Простые звонки» и пароль, пожалуйста обратитесь в службу технической поддержки Ведисофт.

вводим настройки для подключения

5.8. Нажмите кнопку «Подключиться». Через несколько секунд в поле «Состояние подключения» должна появиться надпись «Есть соединение».

5.9. Вы можете задать дополнительные настройки:

задаем дополнительные настройки

- Показывать окно входящего вызова
Выберите, в каком случае следует показывать окно входящего вызова
- Показывать окно исходящего вызова
Выберите, в каком случае следует показывать окно исходящего вызова
- Создавать входящее событие звонок
Выберите, в каком случае следует создавать входящее взаимодействие событие звонок
- Создавать исходящее событие звонок
Выберите, в каком случае следует создавать исходящее взаимодействие событие звонок
- Показывать созданное событие звонок
Выберите, в каком случае следует показывать автоматически созданное взаимодействие событие звонок
- Сохранять историю звонков в журнал Простые звонки
Выберите, в каком случае следует сохранять историю звонков в собственный журнал Простые звонки
- Использовать автоматическую переадресацию
Включает или выключает функцию автоматической переадресации на данной базе 1С


6. Удаление модуля «Простые звонки – 1С»

6.1. Перед удалением модуля «Простые звонки – 1С» сделайте резервную копию базы 1С.

Внимание! Удаление модуля «Простые звонки – 1С» из конфигурации 1С должен проводить квалифицированный программист 1С.

6.2. Откройте базу 1С в режиме «Конфигуратор». С помощью глобального поиска найдите всё, что относится к модулю «Простые звонки – 1С». Поиск необходимо вести по ключевому слову «CTI». Аккуратно удалите код, который относится к модулю.

6.3. Нажмите F7, чтобы обновить конфигурацию базы 1С.

6.4. Удалите компонент ActiveX на компьютерах пользователей «Простых звонков». Откройте «Панель управления» - «Установка и удаление программ». В списке установленных программ найдите «Простые звонки». Удалите программу «Простые звонки».

7. Возможные проблемы и пути их решения

7.1. При запуске появляется сообщение об ошибке «Не удалось инициализировать компоненту Простые звонки», «Не удалось подключиться к серверу с помощью компоненты Простые звонки» или подобное.

Причина
На компьютере не установлен компонент ActiveX.

Решение
Установите компонент ActiveX на компьютер пользователя Установка компонента ActiveX на компьютеры пользователей 1С

7.2. В настройках модуля состояние подключения к серверу отображается как «Нет соединения»

Причина
Настройки подключения заданы неправильно

Решение
Проверьте, что вы корректно указали все необходимые параметры в настройках модуля.

Внимание! Все поля в настройках расширения являются обязательными для заполнения, кроме поля «Пароль». Поле «Пароль» может быть пустым только в том случае, когда подключение к АТС-коннектору «Простых звонков», установленному для работы с офисной АТС (Asterisk, Panasonic, Avaya и т.п.), не защищено паролем (пароль настраивается в конфигурационном файле АТС-коннектора).

7.3. В настройках модуля состояние подключения к серверу отображается как «Есть соединение», но при входящих звонках не появляются уведомления, не получается сделать исходящий звонок

Причина
У пользователя не указан внутренний номер телефона или указан внутренний номер, который отличается от внутреннего номера на телефоне пользователя

Решение
1. Задайте пользователю корректный внутренний номер телефона. После внесения изменений перезапустите оболочку 1С.
2. Проверьте, что пользователь может совершать/принимать звонки без участия CRM (у него должна быть настроена программа софтфон или установлен аппаратный телефон).
3. После совершения звонка из CRM на софтфон или аппаратный телефон поступит входящий звонок, ответьте на него и после этого произойдет набор номера для исходящего звонка.

7.4. Интеграция не работает, в настройках модуля состояние подключения к серверу постоянно меняется с «Подключен» на «Не подключен» и обратно, или состояние подключения «Второе подключение пользователя»

Причины
1. У 2-х или более активных пользователей 1С указан одинаковый внутренний номер телефона
2. На нескольких рабочих местах 1С открыта под одним и тем же пользователем
3. На компьютере есть зависший сеанс пользователя 1С

Решение
1. Внутренний номер телефона у каждого пользователя 1С должен быть уникальным
2. Оставьте только один сеанс работы с 1С под определенным пользователем. Завершите все сеансы 1С, которые были открыты на других компьютерах под одним и тем же пользователем
3. Завершите все зависшие сеансы 1С

7.5. В настройках модуля в строке состояние подключения к серверу отображается «Лицензия истекла»

Причина
Версия платформы 1С отличается от той, которую вы указали при запросе демо-версии или той, лицензию для которой вы приобрели

Решение
Сообщите службе технической поддержки версию свооей платформы и конфигурации 1С. В письме укажите свой пароль (для интеграций с облачными АТС, Android телефонами, софтфонами) или лицензионный ключ (для интеграций с офисными или программными АТС).

8. Не нашли решение своей проблемы?

Сообщите службе технической поддержки :
1. Версию своей платформы и конфигурации 1С
2. Пароль (для интеграций с облачными АТС, Android телефонами, софтфонами) или лицензионный ключ (для интеграций с офисными или программными АТС)
3. Подробное описание проблемы, с которой вы столкнулись
4. Скриншот окна настроек, на котором видно статус подключения к «Простым звонкам»